Symptoms
A new user is added to an existing LDAP group, but the user doesn't pop up in the LDAP list from the Datameer side when an admin searches for that user to add (so that the new user can log in). Rebuilding the LDAP cache or restarting Datameer doesn't make any difference.
Cause
The customer is using "User's Group Membership Constraints:" field (on the LDAP configuration page) and specifies all the specific groups. The new group should be added to this list. The reason that other user accounts belonging to this same group were shown in the list without adding this particular group is that those accounts belonged to another group as well which was added to the list in "User's Group Membership Constraints:".
Resolution
Check the group membership differences for the problematic account and for the other account that belongs to the same group, but successfully pops up in the user list. Creating a new entry in the "User's Group Membership Constraints:" field for the group to which the new user belonged to helped to resolve the issue.
Step 1: login into Datameer and go to Administration tab, then click Authentication.
Step2: In Authentication page, click Edit ( to change the AD/LDAP configuration).
Step 3: click next
Step 4: Add the group details in "User’s Group Membership Constrains” section for the needed group:
Comments
0 comments
Please sign in to leave a comment.