Problem
When a new user has been created, upon logging in for the first time, the follow error may be encountered:
Cause
This is typically caused by a previously existing home directory for the user. Please check the Users section of the Browser with a Datameer admin account to verify that this directory does not already exist. This directory will be created upon the user's first login.
Solution
Remove (if present) the user's home directory. If after removing the home directory the issue persists, careful modification of the MySQL database may be required.
- Take a backup of the Datameer MySQL DB!
- Log into the Datameer DB in MySQL
- Run the following command: `select * from accept_terms`
- The output should resemble the following:
mysql> select * from accept_terms;
+----+-----------------------------+-------------+-----------+---------+
| id | authenticator_id | is_accepted | principal | version |
+----+-----------------------------+-------------+-----------+---------+
| 1 | das.authenticator.extension | | admin | 0 |
| 2 | das.authenticator.extension | | sagashe | 0 |
| 3 | das.authenticator.extension | | test | 0 |
| 4 | das.authenticator.extension | | superuser | 0 |
| 5 | ldapAuthenticatorExtension | | superuser | 0 |
+----+-----------------------------+-------------+-----------+---------+
5 rows in set (0.00 sec)
- Carefully identify the user in question and the associated id
- Run the following command to remove the user: `DELETE from accept_terms where id=<id of corresponding user>
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