Problem
After applying a new volume license, the Data Volume being reported on the Admin Tab is reporting a significant overage in usage:
This prevents jobs from running.
Cause
Applying a new volume license requires that usage be recalculated. This happens on a predefined interval set by the following property within the default.properties file:
datavolume.calculation.period=1h
If the timer for the above interval just passed - they may be up to a 1 hour wait before data volumes are recalculated properly.
Solution
It is not advised to reduce the value of datavolume.calculation.period. If there are a significant number of jobs - constantly recalculating the used Data Volume may have performance implications.
Since jobs will not run until the Data Volume calculation is triggered and completed, it's possible to get a significantly faster restoration of service by restarting the Datameer conductor. A recalculation is triggered 1 minute after conductor start.
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